Skip to main content

Biometric Fingerprint Activation



  • Official comment
    Josephine Mbire

    Hi Alton,

    Thanks for using our Community Page to bring this issue to our attention. I'd like to provide some basic troubleshooting steps which will help resolve the TouchID problem you've been experiencing.

    1. Uninstall the app from your mobile device.
    2. Switch your phone off.
    3. Switch your phone back on.
    4. Reinstall the app from the Google PlayStore.
    5. Sign in to your Spot app and tap on your profile pic on the top right of your app screen.
    6. Turn your touchID on by sliding the "Biometric Sign In" toggle right.
    7. Enter your PIN-code to confirm the activation.

    Please keep me posted on how this goes.

    Thanks - Jo :)

  • Lehlo

    I have the same problem. I use iOS device. 

  • Josephine Mbire

    Hi Lehlo,

    The same steps have helped with iOS devices too :) except you'd need to reinstall the app from the iOS app store.

    Please try uninstalling the app, switching your phone on and off and reinstalling Spot from your app store.

    Please let me know if it works out or not.

    Kindest Regards - Jo :)




  • Lehlo

    Thank you
    It worked out
    But it’s weird. Why do we have to go through that process before you can activate biometric

  • Josephine Mbire

    Hi Lehlo,

    Glad to hear that it worked out (breathes a huge sigh of relief).

    Your question is totally valid. You shouldn't have to go through extra steps to activate biometric. Our app is technically less than a month old, so we're still working to ensure that we clear out these hiccups.

    I personally love to see early adopters of innovation such as yourself and value the feedback you bring to our attention. We're releasing an app update that will clear a lot of known issues soon, so hopefully, this will be a thing of the past.

    Let me know if you need clarification on anything else and I'll be happy to follow up.

    Cheers - Jo.


Please sign in to leave a comment.